No Image

Watchdog for network devices with Tasmota and Sonoff S26

22/11/2020 juliogonzalez 0

I don’t know how many times I had routers providing access to the internet that would not reboot in case there are problems. Or sometimes the problem is a Raspberry crashing from time to time that I don’t have time to debug.

If it’s the router, the solution would be replacing the router, but it’s not always so trivial. Sometimes you are forced to use your ISP’s router. Sometimes the technology your ISP is using makes very difficult considering an alternative. Remember: here in Spain they sometimes do not disclose connection details or VoIP configuration details. And if you problem is with a Raspberry, you

First advice: if your problem is a router and if you can replace it, go ahead. And consider buying one that supports OpenWrt.

(more…)
No Image

optirun/primusrun on openSUSE Leap 15.2

05/09/2020 juliogonzalez 0

After updating to from openSUSE Leap 15.1 to openSUSE Leap 15.2, the good optirun command stopped working, even with all the Nvidia required packages installed:

$ optirun -b primus ./start.sh  
primus: fatal: failed to load any of the libraries: /usr/lib64/nvidia/libGL.so.1:/usr/lib/nvidia/libGL.so.1
/usr/lib64/nvidia/libGL.so.1: cannot open shared object file: No such file or directory
/usr/lib/nvidia/libGL.so.1: cannot open shared object file: No such file or directory

The thing is that in the end I do not want to switch the graphics card using prime-select, as that means using the card for everything, and requires closing the session.

So thanks to this reddit post I noticed that there could be a solution.

Running (as root):

ln -s /usr/X11R6/lib/libGL.so.1 /usr/lib/nvidia/libGL.so.1
ln -s /usr/X11R6/lib64/libGL.so.1 /usr/lib64/nvidia/libGL.so.1

And ready, optirun runs fine once again. And it seems primusrun works as well.

No Image

How to unbrick a TP-Link TL-WA860RE v1

17/09/2018 juliogonzalez 2

Short story: a member of my family got a refurbished TP-Link repeater TL-WA860RE v1 from Amazon a while ago . He tried to configure it but could not, so just stored it in the box until last month, I came to his home and asked him about the repeater (at that point warranty was already expired).

As he told me he was not able to make it work, I gave it a try: The repeater was able to provide an IP address with DHCP to any computer connected to the Ethernet port, but status LED was always yellow, the WebUI was not available, and of course there was no way of configuring it (no telnet, no SSH, nothing).

In the end I discovered that the previous owner failed to flash a firmware on the device, so I saw a lot of errors regarding USB subsystem, kernel modules and even Squash Filesystem: (more…)

No Image

Evaluación de mi cámara Canon IXUS 130 HS

25/08/2011 juliogonzalez 0

Como alguno ya sabéis, hace meses jubilé mi vieja cámara Pentax de 3.1MP y di el salto a una Canon IXUS 115 HS de 12,1MP. Sigo en el mundo de las compactas porque, honestamente, la mayor parte de las veces lo que quiero es hacer una fotografía sin pensarlo demasiado, y no tener que cargar con el peso de una reflex (a pesar de que, como es lógico, reconozco les reconozco mayor potencial).

(more…)